Poky/GettingStarted/Dependencies

From Yocto Project
Jump to: navigation, search
NOTE: This page is no longer maintained. For a up-to-date build host requirements please see the Quick Start Guide.

Fedora

To run Poky on Fedora (tested on F13 and F14) you will need to install the following dependencies:

yum install patch gcc gcc-c++ texinfo wget diffstat texi2html makeinfo svn chrpath git

If you want to build qemu you will also need

yum install SDL-devel mesa-libGLU-devel mesa-libGL-devel

RHEL/CentOS 6.x

In the 6.x series of RHEL/CentOS all required dependencies are available in the distribution repositories:

yum groupinstall "Development Tools"
yum install patch diffstat texi2html texinfo subversion chrpath git wget

If you want to use qemu you will also need:

yum install SDL-devel mesa-libGL-devel mesa-libGLU-devel

Finally RHEL/CentOS on x86_64 hosts includes 32bit glibc, Poky will try and build various tools with both 32bit and 64bit compatibility. You can either enable this to proceed by installing the headers for 32bit glibc:

yum install glibc-devel.i686 

or alternatively you can disable the 32bit library support by adding NO32LIBS = "1" to your local.conf

RHEL/CentOS 5

There are two options for To run Poky on CentOS (tested on CentOS 5.5) you will need to follow several steps. Poky requires a more recent (2.6) version of Python than is shipped with RHEL/CentOS 5.x and therefore we need to install a Python 2.6 or 2.7 interpreter.

One approach is to use the EPEL repository: https://fedoraproject.org/wiki/EPEL This includes the required Python 2.6 and chrpath but may affect other Python applications running on the system.

With EPEL installed you may follow the instructions for CentOS 6.x above only making note that the name of the 32bit glibc package is glibc-devel.i386 *not* glibc-devel.i686.

Alternativel, to enable use of Poky in a non-intrusive manner the Yocto project provides a standalone Python tarball. Grab the appropriate python-nativesdk-standalone from http://downloads.yoctoproject.org/releases/miscsupport/

This tarball also includes the chrpath utility.

Add the python directory to your PATH:

/opt/poky/sysroots/x86_64-pokysdk-linux/usr/bin/python

or

/opt/poky/sysroots/i586-pokysdk-linux/usr/bin/python

Next you will need to install the required package dependencies:

yum groupinstall "Development Tools"
yum install patch diffstat texi2html texinfo cvs subversion git wget

If you want to use qemu you will also need:

yum install SDL-devel mesa-libGL-devel mesa-libGLU-devel

Finally CentOS on x86_64 hosts includes 32bit glibc, Poky will try and build various tools with both 32bit and 64bit compatibility. You can either enable this to proceed by installing the headers for 32bit glibc:

yum install glibc-devel.i386 

or alternatively you can disable the 32bit library support by adding NO32LIBS = "1" to your local.conf

Personal tools